CVE-2017-17663

Published: 06 February 2018

The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
mini-httpd
Launchpad, Ubuntu, Debian
Upstream
Released (1.28)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.30-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.30-2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)