Your submission was sent successfully! Close

CVE-2017-17524

Published: 14 December 2017

library/www_browser.pl in SWI-Prolog 7.2.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
swi-prolog
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Needed

cosmic Ignored
(reached end-of-life)
disco Ignored
(reached end-of-life)
eoan Ignored
(reached end-of-life)
focal Needed

groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Needed

jammy Needed

precise Does not exist

trusty Does not exist
(trusty was needed)
upstream Needed

xenial Ignored
(end of standard support, was needed)
zesty Ignored
(reached end-of-life)