Your submission was sent successfully! Close

CVE-2017-17509

Published: 11 December 2017

In HDF5 1.10.1, there is an out of bounds write vulnerability in the function H5G__ent_decode_vec in H5Gcache.c in libhdf5.a. For example, h5dump would crash or possibly have unspecified other impact someone opens a crafted hdf5 file.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
hdf5
Launchpad, Ubuntu, Debian
Upstream
Released (1.10.4+repack-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1.10.4+repack-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.10.4+repack-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.10.4+repack-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed