CVE-2017-16938

Published: 24 November 2017

A global buffer overflow in OptiPNG 0.7.6 allows remote attackers to cause a denial-of-service attack or other unspecified impact with a maliciously crafted GIF format file, related to an uncontrolled loop in the LZWReadByte function of the gifread.c file.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
optipng
Launchpad, Ubuntu, Debian
Upstream
Released (0.7.6-1.1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(0.7.6-1.1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.7.6-1.1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.7.6-1.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.7.6-1.1)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)