Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-16912

Published: 31 January 2018

The "get_pipe()" function (drivers/usb/usbip/stub_rx.c) in the Linux Kernel before version 4.14.8, 4.9.71, and 4.4.114 allows attackers to cause a denial of service (out-of-bounds read) via a specially crafted USB over IP packet.

From the Ubuntu Security Team

It was discovered that the USB over IP implementation in the Linux kernel did not validate endpoint numbers. A remote attacker could use this to cause a denial of service (system crash).

Priority

Medium

Cvss 3 Severity Score

5.9

Score breakdown

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-10.11)
upstream
Released (4.15~rc4)
artful Ignored
(end of life)
cosmic Not vulnerable
(4.15.0-20.21)
trusty
Released (3.13.0-157.207)
xenial
Released (4.4.0-119.143)
Patches:
Introduced by

1da177e4c3f41524e886b7f1b8a0c1fc7321cac2

Fixed by 635f545a7e8be7596b9b2b6a43cab6bbd5a88e43
linux-armadaxp
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.15~rc4)
artful Does not exist

cosmic Does not exist

trusty Does not exist

xenial Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
upstream
Released (4.15~rc4)
artful Does not exist

cosmic Not vulnerable
(4.15.0-1007.7)
trusty
Released (4.4.0-1016.16)
xenial
Released (4.4.0-1054.63)
linux-azure
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
upstream
Released (4.15~rc4)
artful Does not exist

cosmic Not vulnerable
(4.15.0-1009.9)
trusty Not vulnerable
(4.15.0-1023.24~14.04.1)
xenial
Released (4.15.0-1013.13~16.04.2)
linux-flo
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.15~rc4)
artful Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
xenial Ignored
(abandoned)
linux-gcp
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
upstream
Released (4.15~rc4)
artful Does not exist

cosmic Not vulnerable
(4.15.0-1006.6)
trusty Does not exist

xenial
Released (4.15.0-1014.14~16.04.1)
linux-gke
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.15~rc4)
artful Does not exist

cosmic Does not exist

trusty Does not exist

xenial Ignored
(end of standard support, was needed)
linux-goldfish
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.15~rc4)
artful Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
xenial Ignored
(end of life, was needed)
linux-grouper
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.15~rc4)
artful Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable

upstream
Released (4.15~rc4)
artful Does not exist

cosmic Does not exist

trusty Does not exist

xenial
Released (4.15.0-24.26~16.04.1)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-1003.3~18.04.1)
upstream
Released (4.15~rc4)
cosmic Does not exist

trusty Does not exist

xenial Not vulnerable
(4.15.0-1002.2)
linux-euclid
Launchpad, Ubuntu, Debian
bionic Does not exist

upstream
Released (4.15~rc4)
artful Does not exist

cosmic Does not exist

trusty Does not exist

xenial Ignored
(was needed ESM criteria)
linux-oem
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.3)
upstream
Released (4.15~rc4)
artful Does not exist

cosmic Not vulnerable
(4.15.0-1004.5)
trusty Does not exist

xenial Ignored
(end of standard support, was needed)
linux-hwe-edge
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Not vulnerable
(4.18.0-8.9~18.04.1)
cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial
Released (4.15.0-24.26~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Not vulnerable
(4.15.0-1002.2)
cosmic Not vulnerable
(4.15.0-1008.8)
trusty Does not exist

upstream
Released (4.15~rc4)
xenial
Released (4.4.0-1020.25)
linux-linaro-omap
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

linux-linaro-shared
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

linux-linaro-vexpress
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

linux-lts-quantal
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

linux-lts-saucy
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [end of standard support])
upstream
Released (4.15~rc4)
xenial Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Ignored
(end of life, was needs-triage)
upstream
Released (4.15~rc4)
xenial Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [end of standard support])
upstream
Released (4.15~rc4)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty
Released (4.4.0-119.143~14.04.1)
upstream
Released (4.15~rc4)
xenial Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.15~rc4)
xenial Does not exist

linux-mako
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.15~rc4)
xenial Ignored
(abandoned)
linux-manta
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist
(trusty was ignored [abandoned])
upstream
Released (4.15~rc4)
xenial Does not exist

linux-qcm-msm
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(4.15.0-1006.7)
cosmic Not vulnerable
(4.15.0-1010.11)
trusty Does not exist

upstream
Released (4.15~rc4)
xenial
Released (4.4.0-1086.94)
linux-snapdragon
Launchpad, Ubuntu, Debian
artful
Released (4.4.0-1088.93)
bionic Not vulnerable

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial
Released (4.4.0-1088.93)
linux-ti-omap4
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

trusty Does not exist

upstream
Released (4.15~rc4)
xenial Does not exist

Severity score breakdown

Parameter Value
Base score 5.9
Attack vector Network
Attack complexity High
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H