Your submission was sent successfully! Close

CVE-2017-16869

Published: 17 November 2017

** DISPUTED ** p_mach.cpp in UPX 3.94 allows remote attackers to cause a denial of service (invalid memory access and application crash) or possibly have unspecified other impact via a crafted Mach-O file, related to canPack and unpack functions. NOTE: the vendor has stated "there is no security implication whatsoever."

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
upx-ucl
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Not vulnerable
(3.94-4)
cosmic Not vulnerable
(3.94-4)
disco Not vulnerable
(3.94-4)
eoan Not vulnerable
(3.94-4)
focal Not vulnerable
(3.94-4)
groovy Not vulnerable
(3.94-4)
hirsute Not vulnerable
(3.94-4)
impish Not vulnerable
(3.94-4)
jammy Not vulnerable
(3.94-4)
precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream
Released (3.94-4)
xenial Ignored
(end of standard support, was needed)
zesty Ignored
(reached end-of-life)