CVE-2017-16831

Published: 15 November 2017

coffgen.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.29.1, does not validate the symbol count, which allows remote attackers to cause a denial of service (integer overflow and application crash, or excessive memory allocation) or possibly have unspecified other impact via a crafted PE file.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
binutils
Launchpad, Ubuntu, Debian
Upstream
Released (2.29.90.20180122-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.30-21ubuntu1~18.04)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.30-21ubuntu1~18.04)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.30-21ubuntu1~18.04)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=6cee897971d4d7cd37d2a686bb6d2aa3e759c8ca