Your submission was sent successfully! Close

CVE-2017-16667

Published: 8 November 2017

backintime (aka Back in Time) before 1.1.24 did improper escaping/quoting of file paths used as arguments to the 'notify-send' command, leading to some parts of file paths being executed as shell commands within an os.system call in qt4/plugins/notifyplugin.py. This could allow an attacker to craft an unreadable file with a specific name to run arbitrary shell commands.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
backintime
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Needed

cosmic Not vulnerable
(1.1.24-0.1)
disco Not vulnerable
(1.1.24-0.1)
eoan Not vulnerable
(1.1.24-0.1)
focal Not vulnerable
(1.1.24-0.1)
groovy Not vulnerable
(1.1.24-0.1)
hirsute Not vulnerable
(1.1.24-0.1)
impish Not vulnerable
(1.1.24-0.1)
jammy Not vulnerable
(1.1.24-0.1)
precise Does not exist

trusty Does not exist
(trusty was needed)
upstream
Released (1.1.24-0.1)
xenial Ignored
(end of standard support, was needed)
zesty Ignored
(reached end-of-life)