CVE-2017-16654

Published: 06 August 2018

An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The Intl component includes various bundle readers that are used to read resource bundles from the local filesystem. The read() methods of these classes use a path and a locale to determine the language bundle to retrieve. The locale argument value is commonly retrieved from untrusted user input (like a URL parameter). An attacker can use this argument to navigate to arbitrary directories via the dot-dot-slash attack, aka Directory Traversal.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
symfony
Launchpad, Ubuntu, Debian
Upstream
Released (3.4.0+dfsg-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.4.15+dfsg-2ubuntu4)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.4.15+dfsg-2ubuntu4)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.4.6+dfsg-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist