CVE-2017-16138

Published: 07 June 2018

The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
node-mime
Launchpad, Ubuntu, Debian
Upstream
Released (2.3.1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.4.4+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed