CVE-2017-15922

Published: 26 October 2017

In GNU Libextractor 1.4, there is an out-of-bounds read in the EXTRACTOR_dvi_extract_method function in plugins/dvi_extractor.c.

From the Ubuntu security team

It was discovered that Libextractore incorrectly handled certain crafted files. An attacker could possibly use this issue to cause a denial of service.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
libextractor
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.3-4+deb9u1, 1:1.6-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:1.6-2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1:1.6-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:1.6-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:1.6-2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:1.3-4+deb9u3build0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)