Your submission was sent successfully! Close

CVE-2017-15589

Published: 18 October 2017

An issue was discovered in Xen through 4.9.x allowing x86 HVM guest OS users to obtain sensitive information from the host OS (or an arbitrary guest OS) because intercepted I/O operations can cause a write of data from uninitialized hypervisor stack memory.

Notes

AuthorNote
mdeslaur
hypervisor packages are in universe. For
issues in the hypervisor, add appropriate
tags to each section, ex:
Tags_xen: universe-binary
Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
xen
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic
Released (4.9.2-0ubuntu1)
cosmic Not vulnerable
(4.9.2-0ubuntu1)
disco Not vulnerable
(4.9.2-0ubuntu1)
precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream
Released (4.9.1)
xenial
Released (4.6.4-0ubuntu1.4)
zesty Ignored
(reached end-of-life)
Binaries built from this source package are in Universe and so are supported by the community.