CVE-2017-15135

Published: 24 January 2018

It was found that 389-ds-base since 1.3.6.1 up to and including 1.4.0.3 did not always handle internal hash comparison operations correctly during the authentication process. A remote, unauthenticated attacker could potentially use this flaw to bypass the authentication process under very rare and specific circumstances.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
389-ds-base
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.7.9-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.3.7.10-1ubuntu1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.3.7.10-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.3.7.10-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.3.7.10-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Other: https://bugzilla.redhat.com/attachment.cgi?id=1388078

Notes

AuthorNote
leosilva
code in trusty and xenial are quite different from patch.

References