CVE-2017-15134

Published: 01 March 2018

A stack buffer overflow flaw was found in the way 389-ds-base 1.3.6.x before 1.3.6.13, 1.3.7.x before 1.3.7.9, 1.4.x before 1.4.0.5 handled certain LDAP search filters. A remote, unauthenticated attacker could potentially use this flaw to make ns-slapd crash via a specially crafted LDAP request, thus resulting in denial of service.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
389-ds-base
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.7.9-1, 1.4.0.5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.4.0.18-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.4.0.18-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.4.0.18-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.3.7.9-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Other: https://pagure.io/389-ds-base/c/6aa2acdc3cad97ebec2a6d59d479a15e89bbb3a0