CVE-2017-15095

Published: 06 February 2018

A deserialization flaw was discovered in the jackson-databind in versions before 2.8.10 and 2.9.1, which could allow an unauthenticated user to perform code execution by sending the maliciously crafted input to the readValue method of the ObjectMapper. This issue extends the previous flaw CVE-2017-7525 by blacklisting more classes that could be used maliciously.

From the Ubuntu security team

It was discovered that Jackson Databind incorrectly handled deserialization. An attacker could possibly use this issue to execute arbitrary code.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
jackson-databind
Launchpad, Ubuntu, Debian
Upstream
Released (2.9.1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.9.1-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.9.1-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.9.1-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.9.1-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
libjackson-json-java
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.9.13-2)
Ubuntu 20.10 (Groovy Gorilla) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.9.2-7ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist