Your submission was sent successfully! Close

CVE-2017-15093

Published: 23 January 2018

When api-config-dir is set to a non-empty value, which is not the case by default, the API in PowerDNS Recursor 4.x up to and including 4.0.6 and 3.x up to and including 3.7.4 allows an authorized user to update the Recursor's ACL by adding and removing netmasks, and to configure forward zones. It was discovered that the new netmask and IP addresses of forwarded zones were not sufficiently validated, allowing an authenticated user to inject new configuration directives into the Recursor's configuration.

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
pdns-recursor
Launchpad, Ubuntu, Debian
Upstream
Released (4.0.7-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.1.1-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.1.1-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.1.1-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.1.1-2)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)