CVE-2017-14313

Published: 12 September 2017

The shibboleth_login_form function in shibboleth.php in the Shibboleth plugin before 1.8 for WordPress is prone to an XSS vulnerability due to improper use of add_query_arg().

Priority

Medium

CVSS 3 base score: 6.1

Status

Package Release Status
wordpress-shibboleth
Launchpad, Ubuntu, Debian
Upstream
Released (1.8-1 and 1.4-2+deb9u1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.4-2+deb8u1build0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.4-2+deb8u1build0.14.04.2])
Patches:
Upstream: https://github.com/michaelryanmcneill/shibboleth/commit/1d65ad6786282d23ba1865f56e2fd19188e7c26a