CVE-2017-14180

Published: 15 November 2017

Apport 2.13 through 2.20.7 does not properly handle crashes originating from a PID namespace allowing local users to create certain files as root which an attacker could leverage to perform a denial of service via resource exhaustion or possibly gain root privileges, a different vulnerability than CVE-2017-14179.

Priority

High

CVSS 3 base score: 7.8

Status

Package Release Status
apport
Launchpad, Ubuntu, Debian
Upstream
Released (2.20.8)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.20.1-0ubuntu2.12)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.14.1-0ubuntu3.27)
Patches:
Upstream: https://bazaar.launchpad.net/~apport-hackers/apport/trunk/revision/3171