Your submission was sent successfully! Close

CVE-2017-14051

Published: 31 August 2017

An integer overflow in the qla2x00_sysfs_write_optrom_ctl function in drivers/scsi/qla2xxx/qla_attr.c in the Linux kernel through 4.12.10 allows local users to cause a denial of service (memory corruption and system crash) by leveraging root access.

From the Ubuntu security team

It was discovered that an integer overflow existed in the sysfs interface for the QLogic 24xx+ series SCSI driver in the Linux kernel. A local privileged attacker could use this to cause a denial of service (system crash).

Priority

Low

CVSS 3 base score: 4.4

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.13.0-16.19)
Patches:
Introduced by b7cc176c9eb3aa6989ac099efd8bdd6d0eaa784a
Fixed by e6f77540c067b48dee10f1e33678415bfcc89017
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1001.1)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1002.2)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1001.1)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.18.0-8.9~18.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1002.2)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1002.3)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.13.0-1005.5)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.14~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist