Your submission was sent successfully! Close

CVE-2017-14041

Published: 30 August 2017

A stack-based buffer overflow was discovered in the pgxtoimage function in bin/jp2/convert.c in OpenJPEG 2.2.0. The vulnerability causes an out-of-bounds write, which may lead to remote denial of service or possibly remote code execution.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
openjpeg
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

openjpeg2
Launchpad, Ubuntu, Debian
Upstream
Released (2.3.0)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.3.0-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.3.0-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.1.2-1.1+deb9u2build0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist