CVE-2017-12967

Published: 19 August 2017

The getsym function in tekhex.c in the Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.29, allows remote attackers to cause a denial of service (stack-based buffer over-read and application crash) via a malformed tekhex binary.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
binutils
Launchpad, Ubuntu, Debian
Upstream
Released (2.29-5)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.29-5ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.29-5ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.29-5ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Other: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=patch;h=de25939739ffe9a9ad7cec07a35bb2a1e430fe39