CVE-2017-12958

Published: 18 August 2017

There is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
pspp
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.1-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.0.1-1)
Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.0.1-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected)