CVE-2017-12613

Published: 24 October 2017

When apr_time_exp*() or apr_os_exp_time*() functions are invoked with an invalid month field value in Apache Portable Runtime APR 1.6.2 and prior, out of bounds memory may be accessed in converting this value to an apr_time_exp_t value, potentially revealing the contents of a different static heap value or resulting in program termination, and may represent an information disclosure or denial of service vulnerability to applications which call these APR functions with unvalidated external input.

Priority

Low

CVSS 3 base score: 7.1

Status

Package Release Status
apr
Launchpad, Ubuntu, Debian
Upstream
Released (1.6.1, 1.6.3-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.6.3-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.6.3-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.6.3-2)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed