Your submission was sent successfully! Close

CVE-2017-12564

Published: 5 August 2017

In ImageMagick 7.0.6-2, a memory leak vulnerability was found in the function ReadMATImage in coders/mat.c, which allows attackers to cause a denial of service.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
imagemagick
Launchpad, Ubuntu, Debian
artful Not vulnerable
(8:6.9.7.4+dfsg-16ubuntu2)
bionic Not vulnerable
(8:6.9.7.4+dfsg-16ubuntu2)
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (8:6.9.7.4+dfsg-16)
xenial Ignored

zesty Ignored
(reached end-of-life)

Notes

AuthorNote
mdeslaur
0106-Memory-leak-in-mat-coder.patch in unstable
0272-CVE-2017-12564-Fix-memory-leak-in-ReadMATImage.patch in wheezy
not fixing memory leak in trusty and xenial

References

Bugs