Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2017-12165

Published: 27 July 2018

It was discovered that Undertow before 1.4.17, 1.3.31 and 2.0.0 processes http request headers with unusual whitespaces which can cause possible http request smuggling.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
undertow
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Needed

cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan
Released (2.0.23-1)
focal
Released (2.0.23-1)
groovy
Released (2.0.23-1)
hirsute
Released (2.0.23-1)
impish
Released (2.0.23-1)
jammy
Released (2.0.23-1)
kinetic
Released (2.0.23-1)
lunar Does not exist

mantic Does not exist

trusty Does not exist

upstream Needed

xenial Needed

zesty Ignored
(end of life)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact High
Availability impact None
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N