CVE-2017-11636

Published: 26 July 2017

GraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.

From the Ubuntu security team

It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
graphicsmagick
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.3.26-4)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.3.26-4)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.3.26-4)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.3.23-1ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr) Needed