Your submission was sent successfully! Close

CVE-2017-11535

Published: 22 July 2017

When ImageMagick 7.0.6-1 processes a crafted file in convert, it can lead to a heap-based buffer over-read in the WritePSImage() function in coders/ps.c.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
imagemagick
Launchpad, Ubuntu, Debian
artful Not vulnerable
(8:6.9.7.4+dfsg-16ubuntu2)
bionic Not vulnerable
(8:6.9.7.4+dfsg-16ubuntu2)
precise Does not exist

trusty Does not exist
(trusty was released [8:6.7.7.10-6ubuntu3.11])
upstream Needed

xenial
Released (8:6.8.9.9-7ubuntu5.11)
zesty Ignored
(reached end-of-life)

Notes

AuthorNote
mdeslaur
0096-CVE-2017-11535-heap-based-overflow-in-ps.c.patch in unstable
0083-CVE-2017-11535-heap-based-overflow-in-ps.c.patch in stretch
0251-CVE-2017-11535-Fix-buffer-over-read-in-convert-WritePSImage.patch in wheezy
0270-CVE-2017-11535.patch in jessie

References

Bugs