CVE-2017-11464

Published: 19 July 2017

A SIGFPE is raised in the function box_blur_line of rsvg-filter.c in GNOME librsvg 2.40.17 during an attempted parse of a crafted SVG file, because of incorrect protection against division by zero.

Priority

Low

CVSS 3 base score: 7.8

Status

Package Release Status
librsvg
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.40.18-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.40.18-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.40.13-3ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [code not present])
Patches:
Upstream: https://git.gnome.org/browse/librsvg/commit/?id=ecf9267a24b2c3c0cd211dbdfa9ef2232511972a