CVE-2017-10979

Published: 17 July 2017

An FR-GV-202 issue in FreeRADIUS 2.x before 2.2.10 allows "Write overflow in rad_coalesce()" - this allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
freeradius
Launchpad, Ubuntu, Debian
Upstream
Released (3.0.12+dfsg-3)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.2.8+dfsg-0.1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [2.1.12+dfsg-1.2ubuntu8.2])
Patches:
Upstream: https://github.com/FreeRADIUS/freeradius-server/commit/ae3ba0011e7d299e92c45300e0137a56a650e8f5