CVE-2017-10791

Published: 02 July 2017

There is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
pspp
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.0-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.0.1-1)
Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.0.1-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

Patches:
Upstream: http://git.savannah.gnu.org/cgit/pspp.git/commit/?id=41c6f5447941e5d36d0554ba874671649353752f