CVE-2017-10789

Published: 01 July 2017

The DBD::mysql module through 4.043 for Perl uses the mysql_ssl=1 setting to mean that SSL is optional (even though this setting's documentation has a "your communication with the server will be encrypted" statement), which allows man-in-the-middle attackers to spoof servers via a cleartext-downgrade attack, a related issue to CVE-2015-3152.

Priority

Low

CVSS 3 base score: 5.9

Status

Package Release Status
libdbd-mysql-perl
Launchpad, Ubuntu, Debian
Upstream
Released (4.046-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.046-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.046-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.046-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Ubuntu 12.04 ESM (Precise Pangolin) Needed