Your submission was sent successfully! Close

CVE-2017-10690

Published: 9 February 2018

In previous versions of Puppet Agent it was possible for the agent to retrieve facts from an environment that it was not classified to retrieve from. This was resolved in Puppet Agent 5.3.4, included in Puppet Enterprise 2017.3.4

Notes

AuthorNote
mdeslaur
per Debian, only affects puppet 5.x
Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
puppet
Launchpad, Ubuntu, Debian
artful Not vulnerable
(4.10.4-2ubuntu1)
precise Does not exist

trusty Not vulnerable
(3.4.3-1ubuntu1.3)
upstream
Released (5.3.4)
xenial Not vulnerable
(3.8.5-2ubuntu0.1)