CVE-2017-1000480

Published: 03 January 2018

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
smarty3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.1.31+20161214.1.c7d42e4+selfpack1-3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.1.31+20161214.1.c7d42e4+selfpack1-3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.1.31+20161214.1.c7d42e4+selfpack1-3)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist