Your submission was sent successfully! Close

CVE-2017-1000472

Published: 03 January 2018

The ZipCommon::isValidPath() function in Zip/src/ZipCommon.cpp in POCO C++ Libraries before 1.8 does not properly restrict the filename value in the ZIP header, which allows attackers to conduct absolute path traversal attacks during the ZIP decompression, and possibly create or overwrite arbitrary files, via a crafted ZIP file, related to a "file path injection vulnerability".

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
poco
Launchpad, Ubuntu, Debian
Upstream
Released (1.8.0-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.8.0.1-1ubuntu4)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.3.6p1-5.1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.3.6p1-4+deb7u1build1)