CVE-2017-1000456

Published: 02 January 2018

freedesktop.org libpoppler 0.60.1 fails to validate boundaries in TextPool::addWord, leading to overflow in subsequent calculations.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
poppler
Launchpad, Ubuntu, Debian
Upstream
Released (0.61)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.41.0-0ubuntu1.6)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.24.5-2ubuntu4.9])
Patches:
Upstream: https://cgit.freedesktop.org/poppler/poppler/commit/?id=7ee9dadef37b20bca707a6b1e858e17d191e368b