Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2016-9841

Published: 23 May 2017

inffast.c in zlib 1.2.8 might allow context-dependent attackers to have unspecified impact by leveraging improper pointer arithmetic.

Notes

AuthorNote
mdeslaur
since 3.1.3-7, rsync builds with the system zlib

Priority

Low

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
klibc
Launchpad, Ubuntu, Debian
bionic
Released (2.0.4-9ubuntu2.2+esm1)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
focal
Released (2.0.7-1ubuntu5.2)
jammy
Released (2.0.10-4ubuntu0.1)
mantic
Released (2.0.13-1ubuntu0.1)
noble
Released (2.0.13-4ubuntu0.1)
trusty
Released (2.0.3-0ubuntu1.14.04.3+esm3)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream Needs triage

xenial
Released (2.0.4-8ubuntu1.16.04.4+esm2)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
rsync
Launchpad, Ubuntu, Debian
bionic
Released (3.1.2-2.1ubuntu1.1)
disco
Released (3.1.3-6)
eoan
Released (3.1.3-6)
focal
Released (3.1.3-6)
groovy
Released (3.1.3-6)
hirsute
Released (3.1.3-6)
impish
Released (3.1.3-6)
jammy
Released (3.1.3-6)
kinetic
Released (3.1.3-6)
lunar
Released (3.1.3-6)
mantic
Released (3.1.3-6)
noble
Released (3.1.3-6)
trusty Not vulnerable
(code not present)
upstream Needs triage

xenial
Released (3.1.1-3ubuntu1.3)
zlib
Launchpad, Ubuntu, Debian
artful Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
bionic Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
cosmic Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
disco Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
eoan Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
focal Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
groovy Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
hirsute Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
impish Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
jammy Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
kinetic Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
lunar Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
mantic Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
noble Not vulnerable
(1:1.2.11.dfsg-0ubuntu2)
precise Ignored
(end of life)
trusty Needed

upstream
Released (1.2.9)
xenial
Released (1:1.2.8.dfsg-2ubuntu4.3)
yakkety Ignored
(end of life)
zesty Ignored
(end of life)
Patches:
upstream: https://github.com/madler/zlib/commit/9aaec95e82117c1cb0f9624264c3618fc380cecb

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H