CVE-2016-9487

Published: 13 July 2018

EpubCheck 4.0.1 does not properly restrict resolving external entities when parsing XML in EPUB files during validation. An attacker who supplies a specially crafted EPUB file may be able to exploit this behavior to read arbitrary files, or have the victim execute arbitrary requests on his behalf, abusing the victim's trust relationship with other entities.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
epubcheck
Launchpad, Ubuntu, Debian
Upstream
Released (4.0.2-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.0.2-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.0.2-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.0.2-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.0.2-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)