CVE-2016-7998

Published: 18 January 2017

The SPIP template composer/compiler in SPIP 3.1.2 and earlier allows remote authenticated users to execute arbitrary PHP code by uploading an HTML file with a crafted (1) INCLUDE or (2) INCLURE tag and then accessing it with a valider_xml action.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
spip
Launchpad, Ubuntu, Debian
Upstream
Released (3.1.3)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.1.3-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.1.3-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.1.3-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.1.3-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://core.spip.net/projects/spip/repository/revisions/23186
Upstream: https://core.spip.net/projects/spip/repository/revisions/23189
Upstream: https://core.spip.net/projects/spip/repository/revisions/23192