Your submission was sent successfully! Close

CVE-2016-7980

Published: 18 January 2017

Cross-site request forgery (CSRF) vulnerability in ecrire/exec/valider_xml.php in SPIP 3.1.2 and earlier allows remote attackers to hijack the authentication of administrators for requests that execute the XML validator on a local file via a crafted valider_xml request. NOTE: this issue can be combined with CVE-2016-7998 to execute arbitrary PHP code.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
spip
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.1.3-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.1.3-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.1.3-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.1.3-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://core.spip.net/projects/spip/repository/revisions/23200