Your submission was sent successfully! Close

CVE-2016-7948

Published: 13 December 2016

X.org libXrandr before 1.5.1 allows remote X servers to trigger out-of-bounds write operations by leveraging mishandling of reply data.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
libxrandr
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic
Released (2:1.5.1-1)
cosmic
Released (2:1.5.1-1)
disco
Released (2:1.5.1-1)
eoan
Released (2:1.5.1-1)
focal
Released (2:1.5.1-1)
groovy
Released (2:1.5.1-1)
hirsute
Released (2:1.5.1-1)
impish
Released (2:1.5.1-1)
jammy
Released (2:1.5.1-1)
precise Does not exist
(precise was needed)
trusty Does not exist
(trusty was needed)
upstream
Released (1.5.1)
xenial
Released (2:1.5.0-1ubuntu0.1~esm1)
yakkety Ignored
(reached end-of-life)
zesty Ignored
(reached end-of-life)
libxrandr-lts-quantal
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist
(precise was ignored [reached end-of-life])
trusty Does not exist

upstream Needs triage

xenial Does not exist

yakkety Does not exist

zesty Does not exist

libxrandr-lts-raring
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist
(precise was ignored [reached end-of-life])
trusty Does not exist

upstream Needs triage

xenial Does not exist

yakkety Does not exist

zesty Does not exist

libxrandr-lts-saucy
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist
(precise was ignored [reached end-of-life])
trusty Does not exist

upstream Needs triage

xenial Does not exist

yakkety Does not exist

zesty Does not exist

libxrandr-lts-trusty
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist
(precise was needed)
trusty Does not exist

upstream Needs triage

xenial Does not exist

yakkety Does not exist

zesty Does not exist

Notes

AuthorNote
mdeslaur
https://wiki.ubuntu.com/1204_HWE_EOL
sbeattie
same commit as CVE-2016-7947
rodrigo-zaiden
there is a follow up commit, 87227e5f, that fixes
a memory leak introduced in the first commit.

References

Bugs