Your submission was sent successfully! Close

CVE-2016-7914

Published: 16 November 2016

The assoc_array_insert_into_terminal_node function in lib/assoc_array.c in the Linux kernel before 4.5.3 does not check whether a slot is a leaf, which allows local users to obtain sensitive information from kernel memory or cause a denial of service (invalid pointer dereference and out-of-bounds read) via an application that uses associative-array data structures, as demonstrated by the keyutils test suite.

From the Ubuntu security team

It was discovered that an out of bounds read vulnerability existed in the associative array implementation in the Linux kernel. A local attacker could use this to cause a denial of service (system crash) or expose sensitive information.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
Patches:
Introduced by 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
Fixed by 8d4a2ec1e0b41b0cf9a0c5cd4511da7f8e4f3de2
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.6~rc4)