Your submission was sent successfully! Close

CVE-2016-7425

Published: 16 October 2016

The arcmsr_iop_message_xfer function in drivers/scsi/arcmsr/arcmsr_hba.c in the Linux kernel through 4.8.2 does not restrict a certain length field, which allows local users to gain privileges or cause a denial of service (heap-based buffer overflow) via an ARCMSR_MESSAGE_WRITE_WQBUFFER control code.

From the Ubuntu security team

Marco Grassi discovered that the driver for Areca RAID Controllers in the Linux kernel did not properly validate control messages. A local attacker could use this to cause a denial of service (system crash) or possibly gain privileges.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
Patches:
Introduced by 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
Fixed by 7bc2b55a5c030685b399bb65b6baa9ccc3d1f167
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.9~rc1)