CVE-2016-7395

Published: 11 September 2016

SkPath.cpp in Skia, as used in Google Chrome before 53.0.2785.89 on Windows and OS X and before 53.0.2785.92 on Linux, does not properly validate the return values of ChopMonoAtY calls, which allows remote attackers to cause a denial of service (uninitialized memory access and application crash) or possibly have unspecified other impact via crafted graphics data.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
android
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(abandoned)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was ignored [abandoned])
chromium-browser
Launchpad, Ubuntu, Debian
Upstream
Released (53.0.2785.92)
Ubuntu 21.04 (Hirsute Hippo)
Released (55.0.2883.87-0ubuntu1)
Ubuntu 20.10 (Groovy Gorilla)
Released (55.0.2883.87-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (55.0.2883.87-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (55.0.2883.87-0ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (53.0.2785.143-0ubuntu0.16.04.1.1254)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [53.0.2785.143-0ubuntu0.14.04.1.1142])
firefox
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(50.1.0)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(50.1.0+build2-0ubuntu1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(50.1.0+build2-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(50.1.0+build2-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(50.1.0+build2-0ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(50.1.0+build2-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [50.1.0+build2-0ubuntu0.14.04.1])
oxide-qt
Launchpad, Ubuntu, Debian
Upstream
Released (1.17.7)
Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.17.7-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.17.7-0ubuntu0.14.04.1])
thunderbird
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected)
wine-gecko-2.21
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
wine-gecko2.21
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)