Your submission was sent successfully! Close

CVE-2016-6879

Published: 10 April 2017

The X509_Certificate::allowed_usage function in botan 1.11.x before 1.11.31 might allow attackers to have unspecified impact by leveraging a call with more than one Key_Usage set in the enum value.

Notes

AuthorNote
seth-arnold
upstream reports "Introduced in 1.11.0, fixed in 1.11.31"
Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
botan1.10
Launchpad, Ubuntu, Debian
precise Not vulnerable

trusty Does not exist
(trusty was not-affected)
upstream Not vulnerable

xenial Not vulnerable

yakkety Not vulnerable

zesty Not vulnerable

botan1.8
Launchpad, Ubuntu, Debian
precise Not vulnerable

trusty Does not exist

upstream Not vulnerable

xenial Does not exist

yakkety Does not exist

zesty Does not exist