CVE-2016-6328

Published: 31 October 2018

A vulnerability was found in libexif. An integer overflow when parsing the MNOTE entry data of the input file. This can cause Denial-of-Service (DoS) and Information Disclosure (disclosing some critical heap chunk metadata, even other applications' private data).

Priority

Low

CVSS 3 base score: 8.1

Status

Package Release Status
libexif
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.6.21-5.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.6.21-4)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0.6.21-2ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.6.21-1ubuntu1+esm1)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (0.6.20-2ubuntu0.2)
Patches:
Upstream: http://libexif.cvs.sourceforge.net/viewvc/libexif/libexif/libexif/pentax/mnote-pentax-entry.c?r1=1.26&r2=1.27