Your submission was sent successfully! Close

CVE-2016-6303

Published: 16 September 2016

Integer overflow in the MDC2_Update function in crypto/mdc2/mdc2dgst.c in OpenSSL before 1.1.0 allows remote attackers to cause a denial of service (out-of-bounds write and application crash) or possibly have unspecified other impact via unknown vectors.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
openssl
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.2i, 1.0.1u)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.2g-1ubuntu9)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.0.2g-1ubuntu4.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.0.1f-1ubuntu2.20)
Patches:
Upstream: https://git.openssl.org/?p=openssl.git;a=commit;h=2b4029e68fd7002d2307e6c3cde0f3784eef9c83 (1.0.1)
Upstream: https://git.openssl.org/?p=openssl.git;a=commit;h=1027ad4f34c30b8585592764b9a670ba36888269 (1.0.2)
Upstream: https://git.openssl.org/?p=openssl.git;a=commit;h=55d83bf7c10c7b205fffa23fa7c3977491e56c07
openssl098
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)