CVE-2016-6298

Published: 01 September 2016

The _Rsa15 class in the RSA 1.5 algorithm implementation in jwa.py in jwcrypto before 0.3.2 lacks the Random Filling protection mechanism, which makes it easier for remote attackers to obtain cleartext data via a Million Message Attack (MMA).

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
python-jwcrypto
Launchpad, Ubuntu, Debian
Upstream
Released (0.3.2-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.4.2-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.4.2-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.4.2-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.4.2-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist