Your submission was sent successfully! Close

CVE-2016-6132

Published: 30 June 2016

The gdImageCreateFromTgaCtx function in the GD Graphics Library (aka libgd) before 2.2.3 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Priority

Low

CVSS 3 base score: 6.5

Status

Package Release Status
libgd2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.1.1-4ubuntu0.16.04.3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.1.0-3ubuntu0.3)
Patches:
Upstream: https://github.com/libgd/libgd/commit/ead349e99868303b37f5e6e9d9d680c9dc71ff8d (247)
Upstream: https://github.com/libgd/libgd/commit/0878ffde554d6094a357fc1e118321d2e9712d34 (247 tests)
Upstream: https://github.com/libgd/libgd/commit/981060efd6415ed9a08a6aa343e6e195bf65fb47 (248)
Upstream: https://github.com/libgd/libgd/commit/bd0b820b8647feefcace20ae13856f6028c6a4dd (248 tests)
Upstream: https://github.com/libgd/libgd/commit/ff0234f4da6d1116c0baa66eebd8497526f7a5d9 (248 better)
Upstream: https://github.com/libgd/libgd/commit/4d8f54bd0bcede37138db29e371611f334092fc2 (248 more tests)
php5
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses system gd)
php7.0
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses system gd)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist