CVE-2016-6127

Published: 03 July 2017

Cross-site scripting (XSS) vulnerability in Request Tracker (RT) 4.x before 4.0.25, 4.2.x before 4.2.14, and 4.4.x before 4.4.2, when the AlwaysDownloadAttachments config setting is not in use, allows remote attackers to inject arbitrary web script or HTML via a file upload with an unspecified content type.

Priority

Medium

CVSS 3 base score: 6.1

Status

Package Release Status
request-tracker4
Launchpad, Ubuntu, Debian
Upstream
Released (4.4.1-4)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.4.1-4)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.4.1-4)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.4.1-4)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/bestpractical/rt/commit/aebb36bdf32cf1166d945403ab0bae8e034434a9