Your submission was sent successfully! Close

CVE-2016-5713

Published: 6 December 2017

Versions of Puppet Agent prior to 1.6.0 included a version of the Puppet Execution Protocol (PXP) agent that passed environment variables through to Puppet runs. This could allow unauthorized code to be loaded. This bug was first introduced in Puppet Agent 1.3.0.

Notes

AuthorNote
mdeslaur
puppet agent 1.3.0 is in puppet 4.3.0
Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
puppet
Launchpad, Ubuntu, Debian
artful Not vulnerable
(4.10.4-2ubuntu1)
precise Does not exist

trusty Not vulnerable
(code not present)
upstream
Released (4.7.0-1)
xenial Not vulnerable
(code not present)
zesty Ignored
(reached end-of-life)